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Discussion comments by Andy Pepperdine
This document will concentrate on the use of styles in LibreOffice writer. The topic is enormous, so 
we can cover only a tiny fraction of the features available. I hope these are the most useful for you.

What are styles and why should I use them?
When you write a document, you normally want it to look coherent, with all the headings looking 
similar, and all the text either in sans serif, or serif, fonts, etc. You would like the pages to have the 
same style of header and footer.

This is where styles come in. They define the appearance of the document and its various parts.

Writer comes with many pre-defined styles, and they will probably give you enough flexibility to 
prepare you document, and when it looks about right, you can tweak the default values in the 
associated styles to match more precisely your imaginings.

Styles are arranged in a hierarchy. Each style takes most of its attributes from its parent, and then 
modifies some of them. Right click a style name in the list and then select  Modify, and it will take 
you to a window where you can adjust the exact specification of the style. Here you can look 
around to get a feel for what is defined and what it gets from its parent style.

The Organiser tab shows where it inherits its properties from, and lists the ones which are modified 
from the inherited values with their new values.

If the property that you change is normally merely inherited, then be aware that when you have 
modified a style, the new value of the attribute will take precedence over the inherited one from that
point on. If you ever wish to revert to inheritance instead of your explicit change, then use the 
Standard button on the appropriate tab in the style dialog, which will change those properties back 
to inheritance. This will revert all the properties in this tab, so if you only wanted one of them 
reverting, then you will have to ad the others again. Also, if the changed property was downwards to
other styles, then they will also pick up the reverted value again.

Paragraph styles
The main styles you will usually wish to apply and possibly modify to your liking, are the ones 
which define the way paragraphs are laid out. In this context, a paragraph is any body of connected 
text, which includes things like chapter headings, footers and headers of pages, etc. and not just 
what we call a paragraph of continuous text.

To bring up the list of styles already defined use F11, or Styles → Manage Styles, or View → 
Sidebar and select the T icon in the Sidebar, usually on the right side of the window.
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The list of styles can be displayed in various ways shown by the drop down at the bottom of the 
sidebar pane. The Hierarchical format will display them all in the way each is derived from its 
parents, and can be useful as a way of knowing how each gets its attributes.

When you first open a document, it will put you into the Default style. This is the root of the style 
hierarchy, and is not actually a good place to keep for your text. It is much better to immediately 
select a different one, and probably a type of heading so you can put in type in the section title for 
the start of the document. For example, expand the Heading section by clicking the black triangle 
by it, and then select, say, Heading 2. Now when you type your text it will take on the attributes 
defined for this heading type. When you reach the end of the heading and hit Return, it will then 
immediately switch the type you are using to Text Body, which is the default style of the body of 
the text of paragraphs.

To see what style you are using at the cursor location, at the top left in the Formatting toolbar you 
should see a box containing the name of the style in use at that point. If you do not see it, then make
sure you have selected View → Toolbars → Formatting.

To make a paragraph subject to a particular style, place the cursor in the paragraph, and double click
the name of the style in the sidebar list. Alternatively, you can select it from the drop down for the 
style selection box in the formatting toolbar.  This also works if you select one or more paragraphs, 
and the style will be applied to all of them.

Character styles
Some of the tabs in the paragraph style dialog define the way each character looks. These will apply
as the default for every character typed into that paragraph.

However, you may want certain types of text to look different. For example, when making 
references or quotations to other documents or in other languages, or to emphasise a word such as 
the first reference to a term as a definition. This is where character styles come in handy.

The little icons along the top of the style list in the sidebar will bring up lists for different types of 
style. Hover over each one with the mouse will show the tooltip as to what it refers to. The icon 
with a little a symbol is the one for characters.

Right clicking on one of these will bring up the dialog to modify the way each character looks with 
this style. Since paragraphs have a default character style, these come into play only when you have
selected some text, and you can then apply this style to the selected text by double clicking the style
name.

Typically, you may only wish to change the font or language used for a certain type of character, 
say, one used in unusual concepts or names.
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Use of direct formatting

Direct formatting is the name for when you make certain changes manually, and override the style 
definitions. For example, when you select some text and mark it as bold. This text will not take on 
any other attributes of a style, and generally will have to manually undone if necessary. Wherever 
possible, it is advisable to make these changes via styles, and not directly. Direct formatting is really
only useful when the change is for a certain special case and unlikely to appear elsewhere.

For instance, you may be tempted to use bold font for the first use of a term as its definition. But 
then if you subsequently change your mind and want to use italics instead, using a character style 
for them will entail merely changing the style. Whereas if you used direct formatting, then you 
would have to change them all by hand.

There are also some unexpected characteristics of direct formatting. Since they override the style 
definitions, if the style of a paragraph is changed, the direct formatting will probably still apply after
the change, when what you may actually want is to adjust the direct format to the new style.

To clear all direct formatting so that you rely solely on the style definitions, then select the text you 
want to remove it from, and use Format → Clear Direct Formatting.

Page styles
What sort of page you want will be determined by what sort of document you are writing. If it is a 
sort of book, then you might want the left and right pages to be different. If it’s to be published as a 
report, then perhaps the first page is a title page. In any case, you might want headers and footers on
each with titles and page numbers included somewhere. These are all covered by page styles.

The commonest uses are already covered by the default set, but as with other styles, you can modify
these or make new ones based on them.

This is the place to add a background picture (suitably faded, I hope) in order to stamp a uniform 
appearance on all your publicity material.

Multiple columns per page
The Page style also contains the number of columns for text. The text will then flow down the left 
column, and then continue in the next to the right, and so on until the last one is filled, when the text
will then continue onto the next page. It may be useful if you are printing a landscape document, 
and do not want lines that extend over the whole width of the page.

This technique is best used for continuous text flow, and the formatting will follow in the natural 
way. To create separate columns for different aspects of a topic, then Tables are a better way of 
organising the document. (But see also Sections below.)

Just as using CTRL+Return will start a new page, then SHFT+CTRL+Return will start the next 
column, in case you want the next topic to begin in the next column.

2021-04-April.odt Page 3 / 6



2021-04-22 Sundry topics U3A in Bath

Headers and Footers
Headers and Footers must not be confused with Headings. Headings are the leading text for each 
part of a document. Headers and footers are present on every page and their presence or absence is 
defined in the page style.

Other attributes are defined in the Header and Footer styles, such as tab spacing and fonts to be 
used. To put text in them, you just edit the space in the normal view in the normal way. This is the 
usual place to insert page numbers, count of pages, filename and various other things.

To insert a page number, use Insert → Page Number, or other fields can be obtained from Insert → 
Field.

Frame styles
Some things are added into a document in their own frame, and you may not immediately recognise
that it has happened. For example, adding a picture into a paragraph of text is just an add-on to the 
page at the appropriate place. But if you add a caption to the picture, then Writer will create a frame 
to contain both picture and caption to keep them together. In this case, you will want to define what 
a frame looks like and how it appears in the text. Frame styles are designed to do this.

To insert a frame, use Insert → Frame → Frame. It is the Frame style which determines how it is 
anchored, and where the frame as a whole sits, what its background is etc.

Selecting the Frame and right click will enable to adjust its Properties as you wish.

The contents of a frame can be a paragraph, and it defaults to Frame Contents. The position of the 
text in a frame is determined by two things. The Frame Contents style, Alignment tab, controls the  
horizontal positioning by adjusting the justification under the Alignment tab (left, centred, right, 
justified).

But the vertical alignment is set in the Frame Properties, or Frame style, under the Options tab. You 
have to select the frame first to set this, and look in Properties or the Frame style.

Converting raw text to flowing text
If you have a lot of unformatted text, then it is quite easy to format it properly once you have the 
styles defined. Just go through the document placing the cursor in each paragraph in turn and 
double click the style in the sidebar.

Selecting Applied Styles in the selection drop-down under the Styles sidebar can be useful to reduce
the number of styles visible when selecting which one to use. Alternatively, a short list is also 
visible in the Style drop-down shown at the left of the Formatting toolbar.
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Sections
In some instances, you may wish to divide your document into sections. A common reason for this 
is to divide the text into separate pieces, such as the title page, frontispiece, preface, main text, 
citations, appendices, indexes, etc., but you may find other reasons to do it.

The paragraph and character styles are still valid inside a section, but you can identify them by 
using different numbers of columns per page, background colours, and a few other things.

Difference between Sections and Frames
Sections are a part of the text flow in the document, so you can read the text into, through, and then 
out of a section.

Frames are like a separate box of text with its own content. The main text flow runs past it just as it 
would past a picture anchored at the same place. It is worth noting that when you add a caption to a 
picture, Writer automatically produces a frame to surround both in order to keep them together as a 
unit when moving them around.

Other tips

Auto-correct

With this feature, you can make changes as you type which are convenient. If you look under Tools 
→ AutoCorrect → AutoCorrect Options, and the Options tab, you can see a number of items that 
will be automatically detected and adjusted.

One useful one is the conversion of a URL to a genuine link. When the option URL Recognition is 
ticked, then after inserting the URL, an immediately following Enter key will make the conversion 
for you. The link and the text for the link in this case will be the same. Editing the visible text does 
not change the target of the link. The general way to insert a URL is via Insert → Hyperlink, where 
there are many types of link and text can be inserted.

Another one is the ability of quickly adding a (partial) box around a paragraph, which is normally 
done by creating a style and adding the box under the Borders tab. But by ticking the Apply Border 
option, you can add the border by repeating, say, a hyphen a few times and hitting return. It will be 
automatically turned into a line at the bottom of a paragraph. But this is an added feature to just this 
paragraph, not to all of that style.

Numbering of lists

The easiest way to add numbers to your lists is to type the list in using a separate paragraph for each
item. Then, select the whole list and hit the Toggle Numbered List icon in the formatting toolbar (or
hit F12). This creates a standard numbered list.
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To modify the details of the way it looks, select the text again and use Format → Bullets and 
Numbering to adjust to taste.

Similarly, you can make it a list of bullet points using SHFT+F12 or the Toggle Bulleted List icon, 
and make adjustments afterwards as you wish.

If you now put the cursor at the end of the last item in the list and hit Enter, Writer will continue the 
list. To stop it, Toggle the list icon again, and then select the style for the paragraphs as you wish.

Widows and Orphans

These are printer’s terms for lines which get isolated from their contexts by a page or column break.
An orphan is a single line at the bottom of a page. Typically, it is the first line of a paragraph which 
is longer than one line, and so is separated from its contextual paragraph. A widow is a single line at
the top of a page, that is it is the last line of the paragraph at the bottom of the previous page. You 
can control how these work in the paragraph style by setting the number of lines you are willing to 
allow in each orphan or widow under the Text Flow tab. Wikipedia has some techniques for 
alleviating this problem (see references).

Keep headings with the content

It is usually a good idea to make sure that the heading of a section is retained next to the content, 
and not separated by a page or column break. This is accomplished with the option under the Text 
Flow tab that says keep with next paragraph. Often a heading is defined to automatically switch to 
another style at the Enter key at the end of the paragraph when typing, typically, say, the Text Body 
style. This option would then keep the heading with the first paragraph of the text under that 
heading.

References
Some techniques for how to avoid or eliminate orphans and widows can be found here: 
https://en.wikipedia.org/wiki/Widows_and_orphans

The online help for Writer can be found here: 
https://help.libreoffice.org/6.2/en-US/text/swriter/main0000.html?DbPAR=WRITER
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