
2018-06-28 Libreoffice Calc U3A in Bath

Some More Features of Libreoffice Calc

by Andy Pepperdine

Introduction
The spreadsheet processor Calc, part of the Libreoffice suite, has a great many features that you 
may not be aware of. Here we will introduce a few of the possibly more useful ones, covering 
largely creating sequences of numbers, dates and how to print .

Creating a series of numbers
The full documentation for this section is in [1].

If you open an empty sheet, and put a number in any cell, say A1 for convenience. Then click 
somewhere else and click back to A1, you will notice that a black line appears round the selected 
cell, A1. 

What you may have not noticed is the small black square in the bottom right corner of the selected 
square. This is sometimes known as the Fill Handle. When you hover over it, the cursor will change
to an outline of a Greek cross.

Arithmetic series

If the selected cell has a numerical value in it, then if you click on the Fill Handle and hold it while 
dragging the cursor down or right, then the column or row will fill with numbers sequentially, with 
a default difference of one. So if the selected cell contained the number 2, then it would place 3, 4, 
5, 6, 7, … in subsequent cells along the row or column. Downwards or rightwards will generate 
increasing series, upwards or leftwards will create decreasing series, from the starting cell.

If you do not want a difference of one, then if you put in two adjacent cells the first two terms of the
series, select these two cells (with Shift-Click), and then drag the Fill Handle, it will guess you want
an arithmetic sequence with the difference defined by the difference between these first two 
numbers – in the direction you drag the handle.

You can also put in series with empty cells between the elements of the series. For example, 
suppose you have a 6 rows containing data on a particular year, and the topmost cell in the first 
column contains the year number (say, 2000), but the rest of that year is blank. To create the next 
year’s data area, and subsequent years, select the cell containing the 2000, and then Shift-click the 
LAST cell for that year (or the one above the first cell for next year). This will select all the cells 
relating to that year. Now dragging the fill handle will copy the whole block, adding one to each 
cell, if it contains something, into each new block.

Selecting the whole of a two-dimensional block, and dragging the fill handle will add one to each 
corresponding cell, where possible, as it propagates the blocks.
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Non-numeric series

In some cases, you may want to create headings for columns of the days of the week, or months in 
the year. These have been defined by default in Calc. If you place, say, January in a cell, and then 
drag the fill handle, it will create a series of the names of the months. The names of the days of the 
week are also defined by default.

However, if you want a different set of labels, which have a sequence meaningful to you, then going
to Tools → Options → Libreoffice Calc → Sort Lists will show a dialog to define your own series 
as appropriate. I noticed that simple alphabetical order is not there, so that can be defined by you in 
what ever alphabet is suitable for the application.

If you have the series already in a spreadsheet somewhere, then by selecting the full range before 
going to the Options menu, it will place at the bottom, the range you selected. Then to create a new 
list you can merely hit the Copy button and you have it for any future use. Don’t forget to hit the 
New button, or it will discard what you have put in.

Geometric series

Calc can also generate other types of series. To do so, first select the range of cells to be filled in.  
Then use the menu item Sheet → Fill cells → Series … and it will present a dialog to describe what
sort of series you want to create. There you can define an arithmetic series (Linear) or geometric 
series (Growth), or a date series, which will be discussed in the next section of this document.

Date series

To set up a series of dates, first format all the cells that will contain the series as dates. Then by 
placing a date in the first cell and dragging the fill handle to the appropriate end point, you will get 
a series of days. By setting up the first two, then an arithmetic series will appear.

For some series of dates, this is not good enough. For example, dates a calendar month apart are not
in a simple series. But you can still do what you want from the Sheet → Fill cells → Series… 
dialog. By selecting Date as the type, you will see further options to specify what the unit of the 
difference should be, and the lower box contains the number of such units. In this way you can 
generate a series of dates calendar months apart, for example to specify the dates of bank account 
statements.

The Side Pane
On the right hand side is a side-pane. If you do not see it, but only a short list of icons, then press 
the uppermost icon, and Properties, and the pane will appear. This contains a number of useful 
features that you may often wish to adjust. However, it does not replace all of the abilities of the 
menus. In some of the sections, the three small dots at top right will bring up the menu dialog for 
further refinement.

Another of the far right icons, f(x), brings up a list of arithmetic functions which may jog your 
memory on what they do and which one you need for a particular purpose. A very brief (and 
truncated!) description of each appears in the box at the bottom when it is selected. Fortunately, 
when this is selected going to the Help → Libreoffice Help (or use F1) then takes you to the full 
documentation of the functions.
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Date functions

One of the categories of functions that you can see in the drop down for categories is Date & Time.

Times are held to include both the date and a fraction of a day, that is then interpreted as a time of 
day on that date. If you format a cell in a spreadsheet as a Time, then the various options that are 
presented include a full date and time, such as 28/06/2018 14:15:10. If you do this, then if a cell 
shows the error indication ###, it could simply mean that the cell is not wide enough to 
accommodate the whole date and time. To widen the cells in a column, just drag the dividing line 
between the column header and the next one to the desired location.

The function NOW() will put into the cell the exact time taken from the computer’s clock, including
date and time. It is re-evaluated every time the spreadsheet needs to be recalculated. It cannot be 
used a real-time clock in itself.

The functions, YEAR, MONTH, DAY,  HOUR, MINUTE, and SECOND do the obvious thing to 
break apart a time value into its constituent parts.

To do the reverse requires two functions to put the value together, for example, 
=DATEVALUE(“20/06/2018”) + TIMEVALUE(“10:13:44”). The format of the string passed to 
these functions is very versatile – almost anything that looks like a date and/or time will be treated 
sensibly. The DATEVALUE function will ignore any time indicator, and the TIMEVALUE will 
ignore any date indication in the string.

Date difference functions

There are several options to the DATEDIF function to get a difference between two dates in various
units. For example, if cell C3 contains someone’s date of birth, then DATEDIF(C2,NOW(),”y”) will
tell you how old they are now, i.e. how many completed years they have experienced since their 
birth. Similar alternatives to the third parameter can be used to find the number of months, “m”, or 
days, “d”, but also the number of months beyond the whole number of years, “ym”, or days over the
months, “md”.

However, the DATEDIF functions requires that the second parameter be later than the first. If this 
may not be the case, then the YEARS functions can be used. This takes a third parameter to indicate
whether you want the interval between the dates as a number of years, or you want the difference in 
calendar years. Again, the function YEARS(C2,NOW(),0) gives the number of whole years in the 
interval between the dates. But YEARS(C2,NOW(),1) tells you the difference between the years, 
not considering when in the year the date was.

Defining ranges
A range of cells can be given a name for convenience in referring to it. First select all the cells in the
range you wish to include in the range, and then use the menu item Data → Define Range … and it 
will have automatically prepared the range you wish to name. When you supply the name at the top,
the range will become visible. At this point you can edit or re-define as you wish. Hit Add, and the 
name will be defined.

Printing
When your spreadsheets get large, printing can be a cause of frustration, especially if you want to 
see all the data on a single sheet, or well separated and self-contained sheets of data. There are 
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several features of the print preview dialog that can help immensely with this. Go to File → Print 
Preview and then select Format Page from the tool bar, but if that is absent it can be accessed also 
via the menu Format → Page … .

The options can also be found via the Format → Page menu item from the main spreadsheet view.

I will call this dialog the page format dialog.

Printing whole sheets

In the spreadsheet, you will notice that the boundaries of each cell are a shade of grey by default. 
However, after you have looked at the print preview the first time, a larger grid between some 
columns and rows appear as a distinct black and stand out as darker. This wider grid delineates the 
page boundaries when printing.

A common requirement is to print a wider sheet than will fit across an A4 sheet. Using the page 
format dialog, you can switch between portrait and landscape in the Page tab.

If it still does not fit across, then a further reduction in scale can be found under the Sheet tab of the 
page format dialog. Here the drop down list for the Scaling Mode enables you to ask it to select the 
reduction that can be fitted to the paper size you have. If you do so, then the paper size grid will 
also be changed to show you where in the actual spreadsheet the page boundaries are.

There is also the ability to select how they are to be presented on a page, and the number of sheets 
that can be put onto each side of printed paper.

Headers and Footers

The page format dialog is also the place to find tabs to edit the text used for the header and footer 
on each printed page. You will not find the whole of Writer’s features there, but surely enough 
ability to customise the printing for any reasonable use, like size and type of font, page numbers, 
dates and file names etc. Use the Edit button after ticking the Header On or Footer on box in the 
Header or Footer tab respectively. The icons along the lower portion of the edit pane will introduce 
various standard formats for special things like the Filename, Date, Time and Page statistics.

Printing only part of the spreadsheets

A Print Range can be defined which will restrict the printing only to those selected cells. To do this, 
first select the cells you wish to include in the printing, and then use the Format → Print ranges → 
Define menu item. The next print preview will show only those cells in the range just defined. This 
selection will remain until modified by the Format → Print ranges menu again, either to clear it, 
define a new one, or add to or take from the selection.

Hiding rows and columns

Another way of saving space on the paper is to hide rows and/or columns you do not need to see. 
This is done by selecting the whole row or column and then use Format → Row/Column → Hide, 
and the selected items will not appear either in the display, nor in the print-out.

To recover them, use Format → Row/Column → Show and they will re-appear.
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References
[1]  https://help.libreoffice.org/Calc/Fill_Series is the documentation for how to fill a series of cells 
in all its generality.
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