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Conditional Text and Mail Merge
in LibreOffice

by Andy Pepperdine

Introduction
This paper is a simple introduction to how you can produce a number of letters, each customised to 
each addressee, using LibreOffice. The names and addresses are obvious parts that will have to be 
changed, but there may be other bits of text as well. For example, you may want to include the 
account balance, or membership number, or some other specific text that is determined by the 
contents of some database.

For this example, we will use data in a spreadsheet (Calc), although very similar methods can be 
used from a database (Base). The letters are created in Writer.

The same principles can be used to create labels for the envelopes for each letter.

These notes were developed using LibreOffice 4.1.3.2.

Outline of method
There are several steps to set this up to start with. However, once that is done, re-use is simple and 
so the letter can be edited and sent with new text easily enough.

The steps to be carried out are:

1. Build the spreadsheet containing the data to be inserted. Each recipient has their own data in
a row.

2. “Register” the spreadsheet with LibreOffice, so it knows where to get the data from and to 
synchronise with any new data that appears.

3. Write the letter, inserting at the relevant places the values of data items for each recipient.

4. For some places in the text, you may want to place optional text, depending on values in the 
spreadsheet. This can be done next.

5. Save the skeleton letter.

6. Print all the letters.

7. Prepare the labels similarly to a skeleton letter (3 and 4 above), and save it.

8. Print the labels.

When it has been done once, it is easy to repeat with updated data just by doing steps 6 and 8 again;
updates to the spreadsheet will automatically be transferred to the new set of letters and labels.

Each of the steps will now be described in more detail.
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Build the spreadsheet
To make a spreadsheet suitable as a source for data in a merge operation, it must have certain 
characteristics.

First, the data to be extracted should be in the rows. Each recipient has a row to themselves.

Each piece of data (a field) is in a cell of its own. The first cell in each column must contain the 
name of the field. It is this name that is used later to refer to the field to be inserted into the letter.

It is a good idea to name the sheet containing this data with a sensible readable name to make it 
easier to specify when you come to define the source of the data for the letter or labels. To change 
the name of a sheet, right click on the tab at the bottom left of the pane, and select Rename Sheet.

If your data is not presently organised this way, then you can perhaps create another sheet which is, 
and put in cell references to the actual data from other sheets. You would then use this new sheet as 
the source for your mail merge, while leaving your existing systems alone.

Make sure that you have saved the spreadsheet, since it is the saved data that will be referenced 
when merging from it.

Register with LibreOffice
To register the data source, you have to be in Writer, so this is best done when writing the letter to 
contain the customised data. However, registration will apply to all uses by you of any subsequent 
letter, so it does not matter what you are editing when registering the spreadsheet as a data source.

Use Edit → Exchange Database menu item to bring up the registration window and hit Browse. The
name will appear in the list of sources in the right pane. Select it.

Close the window to complete the registration.

Write the letter, customised for the recipient
Any document in Writer can be modified by incorporating text from a spreadsheet, so just write the 
letter as normal, but leave spaces where you want the customised text.

To access the spreadsheet, use the View → Data Sources menu item. A new pane will appear at the 
top of the window. By expanding the name of your data source, you will see a Tables entry. When 
that in turn is expanded, you will see the names of the sheets in your spreadsheet. Select the one you
want to extract data from. The data will appear on the right side of the pane. The names of the 
columns will be taken from the first row of the spreadsheet.

To introduce the value of a particular field at a particular place in the letter, you can click and drag 
from the header of the column to the location where the relevant text is to appear.

Make some text optional
You may want to include some text only for particular recipients. For example, if someone has an 
empty line in their address, it would look odd to have a blank line showing in their address in a 
letter or label. There is a way to determine whether a field is blank in any particular case and omit a 
paragraph.
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For this reason, it is recommended that each line of an address is a separate paragraph, although 
there are ways of adjusting smaller amounts of text.

To omit a whole paragraph, place the cursor at the start of the paragraph, and go to Insert → Fields 
→ Other. In the Fields window, use the Functions tab, and select Hidden Paragraph. In the 
Condition box, you provide the condition under which this paragraph will be hidden. In this case it 
will something like NOT [source.sheet.filename], note the square brackets around the field name.
This example will omit the text when there is no content in the field of that sheet for that data 
source.

Close the window and ensure that View → Hidden Paragraphs is unchecked.

Bits of text can also be made conditional on the existence or value of a field. If you highlight the 
text, and then Insert → Fields → Other → Functions → Hidden Text. The selected text will appear 
in the text box, and you can supply the condition in the usual way.

The reference given at the end of this document describes how to set up variables and set 
conditional text. Follow the link on that page to Defining conditions for details on how to do that.

Save the letter
You can now save the letter in the normal way. It is advisable always to save the letter immediately 
before printing, as I've discovered that the names of the fields may be hidden after the print 
operation. If the letter has been saved, then recovering the visible names is just a matter of reloading
the letter. Another way to recover them is to use Tools → Options → LibreOffice Writer → View 
and tick the Field Codes box.

Print all the letters
When you try to print, LibreOffice reminds you that the letter contains database references, and 
asks whether you wish to print a form letter. Answer Yes.

The next window allows you to select a subset of the total number of entries in the database. Or you
can print all of them. Then click OK.

If you select the Options tab and then Print to File, you can examine the result without wasting 
paper in the printer.

Prepare the labels
Labels can be prepared in exactly the same way. Open Writer with New → Labels and select the 
Sheet type.

Important: If you want to edit just one label and get the others to copy from separate rows, then 
you must select the Options tab and make sure the Synchronise Contents box is ticked. It appears 
that you cannot correct this afterwards.

Now select the database (i.e. spreadsheet) to use as the basis for the data. Then pick out the sheet to 
be used. Finally, you should at this point move the fields across in the right order. Use the dropdown
to see the fields, select each in turn, and use the arrow to transfer to the label text box on the left.

You can also type in some fixed text as well at this point.
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You can now hit the New Document button and you are ready to insert the text into the label. A 
separate little window will also pop up with a button to synchronise the contents of all the labels. If 
this does not happen, then each sheet will contain only a single address. You will have to start again 
with New → Labels and make sure that the Synchronise Contents box is ticked.

Now you are ready to ensure that all the labels are correctly aligned and edited. The first label on 
each sheet is the master label, the others will follow when the Synchronise labels button is hit.

The initial text box will supply carriage returns when you put them in, but will treat the whole text 
as a single paragraph. In order to make other things easier, delete the carriage returns, and replace 
them by new paragraphs. To see these non-printing characters, use View → Nonprinting Characters.

To get a suitable spacing and look of the text, use the paragraph type dropdown and select More, or 
hit F11, to bring up the list of paragraph styles. If you cannot see the Addressee style, make sure 
that the leftmost icon along the top is selected (the pilcrow symbol), and try selecting  Hierarchical 
from the dropdown list at the bottom.

Then right click on Addressee to select Modify. This will enable you to create a space between the 
text and left edge of the label, for example.

Some of the addresses may not contain some lines, so you can now remove those conditionally in 
the same was as in the form letter. Place the cursor ahead of the line which may be absent, and 
Insert → Fields → Other as before.

When you are sure you have the master label correct, click the Synchronise labels button to 
propagate the changes throughout all labels per sheet. If you do not, then only the first on each sheet
will be as you expect, the others may contain older versions of your edited text.

Important: In order that you can ensure that you get only a single label per address, and not a 
whole page per address, go to Tools → Options → LibreOffice Writer → General and make sure 
that On request is ticked under Update links when loading.

Save the document and close the window. You now have a document that can be used to print 
labels.

Print the labels
Reload the label document. You should be prompted whether to update the fields with database 
entries. If not, something is wrong.

Counter-intuitively, answer No to that question.

Now use File → Print. You will be asked whether you want to print a model letter, so answer Yes.

The next window shows the printing options.  If you select File, you can check that the result is as 
expected before actually printing it.

Updating the data
If the data in the spreadsheet is updated, with new rows, changed contents, etc. then the changes 
will be automatically transferred to the letters and labels with no further changes.

The only thing you need to be careful, of, is that if you move the file elsewhere, the data source 
reference from the letter will not follow it, and the letter will look for its data where it was before.
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If you do wish to move the spreadsheet, then you should disconnect it from the Writer data sources. 
Bring up the data source pane with View → Data Sources, and then right click on the relevant 
source file, and select Disconnect. You can then re-register the source at its new location.

Printing the next letter and labels
You can edit the letter in the usual way, inserting further fields and modifying text as normal. When 
you call it up again for printing, it will again insert the up to date information and print as before.

For labels, similarly, if you want to edit the file, just do so. When you open it to print, then just 
follow the instructions above.

References
Another short guide to getting started is at: 
http://davidmburke.com/2011/08/10/mail-merge-in-libreoffice/

The LibreOffice documentation on using the Mail Merge Wizard is at: 
https://help.libreoffice.org/Writer/Mail_Merge_Wizard

Defining conditional text is described at: https://help.libreoffice.org/Writer/Conditional_Text

How to define a condition is described at: https://help.libreoffice.org/Writer/Defining_Conditions

While experimenting, if you want to get some random text to try formatting etc, then there are a 
number of websites that will generate suitable random paragraphs. Searching for the phrase “loren 
ipsum” is a good start to finding something suitable for your needs.
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