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Some (semi-)advanced tips for LibreOffice

by Andy Pepperdine

Introduction
We cover several tips on special things in Writer and Calc – and anything else that turns up. 
Although I use LibreOffice, these should be the same for OpenOffice, at least in the immediate 
future. LibreOffice will be referred to often as LO.

LibreOffice version 4.0
Version 4 has some differences from earlier versions. Where it affects this paper, they will be 
pointed out.

Note: The help pages for LO 4.0 are not yet up to date. Google is your friend when things have 
changed; the forums contain a lot of queries other users have asked with answers.

Templates
A template is a draft document that you can re-use over and over to generate new documents all 
based on the same basic format and with the same headers, footings,  styles and formats defined. In 
this way you can make all your documents look the same. For instance, it enables you to create a 
single template for use whenever you wish to write a letter with a standard header.

You can create a template for use in Writer (text documents), Calc (spreadsheets), Impress 
(presentations), and Draw (drawings).

Creating a template

Creating a template is easy.

First, create the template as though you are creating any other document in writer, but put no text in 
it that you will change for each instance. It is a good idea here to prepare all the styles that you will 
use, set up all the detail for headings and footings on each page, select the languages and fonts that 
you are to use, etc.

When you come to save it, do not save in the normal way. Instead, go to File → Templates → Save. 
There you can select the category for it, and give it a name. These templates are known to LO and 
one can be set as the default.

If you want to be able to transfer the template to somewhere else, then you can use Save As and 
change the file type to .ott via the lower button. For other parts of the LO suite, templates can be 
made similarly, look in the drop down list of the Save As dialog to find the template type you want.

[Version 4: The template handling has changed markedly. To save a new template, use File → Save 
As Template, when a display of each of the folders containing templates appears. Select one by 
clicking on it and then hit the Save button.
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There does appear to be any way of creating new folders in the Save dialog. To organise your 
templates, use File → New → Templates, select the folder with the template you want to adjust, 
double clicking to open the folder. Then single click on the template. (Note: double clicking will 
open the template as a new file to edit). This brings up a number of buttons, one of which is Move 
to folder with a dropdown list of either existing folders, or the ability to create a new one.]

Making a document from the template

To use a template, which you saved using the template menus, use File → New → Templates and 
Documents. This will open a dialog showing all the templates that are installed, including any you 
have created. From there, select the one you want to use, and open it. You can now change any part 
of it and save it like any other document.

[Version 4: Use File → New → Templates. Select the folder with a double click and then open the 
template with a double click.]

To use a template which was saved as a file, just use Open and browse to the .ott file and open it.

Making a template the default

After you have saved a template, you can make it the default for all later documents you start by 
simply File → New → Text document. To do this, go to File → Templates → Organize. In the left 
pane, double click the My Templates line and then select the template below it which you wish to 
make the default. On the right side of the dialog box you will see a Commands button with a drop 
down list. In that list is Set As Default Template, which does what it says.

[Version 4: To organise the folders, use File → New → Template, navigate to the template you 
want as the default, and single click it. One of the buttons will now show Set as default.]

Now, when you start a new document, it will take that template and present it to you as the starting 
point for your work.

Editing a template

Note that changing the template will not change the contents of all documents which were started 
from that template. There is no way to go back through all previous uses of the template. What you 
can do is to change the template so it will affect all subsequent documents made from it.

By going to File → Templates → Edit, you can select the template to change and when you save it 
will save back to where the template was.

[Version 4: File → New → Templates and navigate to the template to be edited. One of the buttons 
will be Edit.]

Alternatively, just open it as though you are going to write a document using it, and save as a 
template as before, overwriting the previous version.

Forms in Writer
Forms are useful for things like questionnaires, where you wish to set up some text which is 
constant, and then provide some boxes and selections which the fill in and select. As well as text 
boxes, you can define radio buttons, tick boxes and other types of input. It is possible to include 
data from a data source, or data base, but that is not what will be described here.
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For a very simple application, consider a form letter that is sent to a client, containing a 
straightforward message, for example that their payment has been received. You could use a form 
for this, which has the advantage of just using a template in that you can protect the bulk of the 
message from any changes, and leave only the fields that are to be completed available to be 
changed.

It is not an ideal use as the fields may have to be lined up very accurately in order not to make the 
text look strange and the text fields will have to be of fixed size, and so cannot be used in normal 
flowing text. But if it is a simple case, then perhaps this is a suitable alternative to templates.

Creating a form

First, write the basic text that you want on the form, and leave spaces where you wish to include 
fields to be filled in on the form. Then bring up the toolbars by View → Toolbars → Form Controls 
and Form Design. This will give you access to the various types of entry fields you want to include.

Make sure that Design Mode is On before trying to create a field. The icon is one with OK and a 
hand in it. If design mode is off, then most of the Form Controls are greyed out.

To add a text box where you can later write some text, select the ABC icon, and draw the space for 
the entry with the cursor.

It may not be exactly what you want, so to change attributes of the text box, select the field (it will 
show green squares), right click and select Control, when a dialog will appear to allow you to 
change many attributes. In particular, you may wish to modify entries under the General tab, e.g. the 
font, border style, background colour etc. You can also change the anchor type between As 
character, Paragraph, etc.

When you are done with the window, you can just close the Properties window.

One of the fields there defines the order of tabbing, so you do not have to fill the fields in natural 
sequence, but define your own.

If you do not want to accidentally modify the form, then you can set it to Read-Only when you 
bring it up. (See below, use File → Properties → Security) Then only the fields can be written to, 
and not the standard text.

Protecting your documents
There are various meaning to the word “protect”. You may wish no one else to read it, or you may 
wish no one else to modify the change logs. These methods apply to all documents that LibreOffice 
can produce.

Protecting the whole document

For instance, if you have a list of private information that you keep (like financial information), then 
you can protect it from others reading it. When you save such a document (use File → Save As), 
tick the “Save with password” box. It will then ask you to supply a password. Any attempt to open 
the document will request the password before access is granted.
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Protecting accidental overwriting

Under the dialog File → Properties → Security tab, you will see two check boxes. Open file 
read-only means that anyone can read the document, but you cannot accidentally change it.

In order to modify a read-only document, open it as read-only, but then save as some other 
document. Saving will change the protection to read-write. You can now change it, and later Save 
As the original name to overwrite if that is what you want. But remember to change the security 
back to Read Only or you will lose that protection.

Protecting the change log

The second box on the Security tab for Properties is Record changes. Ticking this will turn on the 
recording of all changes made to the document – it is the same as Edit → Changes → Record. If 
you want to ensure that the change log is secure, then you can set a password. Any attempt to stop 
the changes being recorded will prompt for the password before it can be turned off.

Protecting change logs will make sure that you have a history of modifications to the document if it 
should ever be necessary to reconstruct the trail of events.

Protecting a template

If you set a template to be read only, then it will prevent it being saved back onto the template 
without first releasing the read-only status. But the downside is that when the template is used to 
create a normal document, then it has first to be saved (Save As) before it can be edited.

Spreadsheets
Here are a few simple tips when using LibreOffice Calc.

Creating a list of sequential numbers

Suppose you want in a column, the numbers 10, 11, 12, 13, etc. then you can do that by first 
inserting the value 10 into the first cell. Then select that cell, and the display changes to show a bold 
line around it. But you will also see a small black square at its lower right corner. By placing the 
cursor on that square, you can drag the cell down (or across) as far as you want to go, and the cells 
will propagate. But since the first is a constant, it will simply add one to each for each cell in turn. 
Otherwise, it will merely copy the cell.

Note that this puts constants into the cells, not formulae that generate the values, so choose this only 
when you are just numbering the cells.

If you put a sequence of letters and digits in the cell, then it will look for either a trailing or leading 
sequence of numbers, and increment that. If both the start and end are numerical. then only the end 
will be incremented. For example, if you start with INV0001, then subsequent ones will be 
INV0002, INV0003, etc.

Creating a more general series

This feature is more general. If you select a set of cells along a column or row, then go to Edit → 
Fill → Series, you can adjust the series to other types of sequence, like dates, days of the week, 
arithmetic or geometric series with varying increments, etc. It seems to convert everything to 
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numbers initially, but if you really want dates, then format the cells (Format → Cells) for the way 
you want to see Dates.

Copying a row (or column)

To add a row to a table, then a similar technique can be used. Select the cells in a row to be copied 
down, and drag the black square, and it will adjust all the entries to refer to the appropriate cell 
names. However, any constants will be used as the start of a sequence with increment one, and this 
may have to be adjusted afterwards if it is not what you want.

Naming constants

If you have a value that is constant for the calculation, for example, the interest rate, then you can 
define it as an easily recognisable name instead of the name of some cell that you use for it.

To do this, select the cell where the value is, and then Insert → Names → Define, where you set the 
value the name represents. When you do that, notice that the cell name changes to the name you 
have given it. In fact, clicking on the dropdown by the cell name will show a Manage Names entry 
which gives you another way to define names.

Naming ranges

Ranges can be named and then used as though picking up one element of them in subsequent 
formulae. To do this, create the table of input values, say by column, and place the name of the 
variable you want to use in the first row of the table. Make the table as long as you need, since you 
can insert rows later in the middle, but not add to the end easily.

To create names for a set of ranges, select the columns (or rows) you want to make names from, and 
use Insert → Names → Create. The dialog then shows options where the names will be found. 
Make sure your selection includes the cells containing the names you want to use.

Then use of the name in a formula will refer to the corresponding entry in that column in the same 
row as the formula cell.

The simple name can also be used for the whole range in functions like SUM.

Mail merge
Creating a set of form letters, or labels, from data held in a spreadsheet (or database) is known as a 
Mail Merge. In fact with LibreOffice, if the data is in a spreadsheet, it must first be turned into a 
database before it can be used by Writer to fill in fields in a form letter.

Creating database from spreadsheets (registration)

Use the File → Wizards → Address Data Source. This leads you through the process of conversion.

In the first window, select Other external data source, and in the second, click Settings, which 
brings up a drop down list from which you select Spreadsheet. The next one asks for the file where 
the spreadsheet is to be found. Clicking Finish takes you back a level in the wizard, where you 
ignore the Field assignments. Skip on to where you give it a location (a database name of type .odb) 
and name the address book.
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Finally, finish.

Creating a form letter

First, select the data source you want to access by going to View → Data Sources and selecting the 
appropriate one. It will be displayed above the text you are writing.

Then write the letter as you would normally, but when it comes to putting in the value from one of 
the fields, drag the column heading to where it should be. If you are writing an address, it is better 
to use separate paragraphs for each line, rather than line breaks within a paragraph.

Omitting empty lines

If you do not like empty lines in addresses, it is possible to remove them by setting a condition on 
the paragraph. The details are in the reference.

Printing all or a selection

You can now print the letter, by the usual means. But when the print dialog comes up, it first asks 
whether you wish to print a form letter. The next window allows you to select the rows from the 
spreadsheet you want to print so you do not have to print all of them.

Further information
You can find a full description of how to set up a form at 
http://wiki.documentfoundation.org/images/0/05/0215WG3-UsingFormsInWriter.odt which shows 
the vast range of possible fields that are available.

Information on Mail Merge can be found at 
http://wiki.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Using_M
ail_Merge

More stuff on making labels is at 
http://blog.worldlabel.com/2011/creating-custom-fancy-address-labels-in-libreoffice.html

Some other tips and oddments about LibreOffice Writer can be found at 
http://www.techrepublic.com/blog/10things/10-essential-libreoffice-writer-tricks/2852
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