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OpenOffice.org Calc spreadsheets

by Andy Pepperdine

This paper starts with the assumption that the reader has some knowledge of what a spreadsheet is 
and how it may be used. We will look at some of the more advanced features, for example, naming 
cells, drawing charts and graphs, and the use of separate sheets

We will not cover macros.

Throughout this paper, there will be some tips included. These are items that came out from 
discussions at the meeting, or immediately after, and I thought worthwhile reporting.

Tip: Double clicking on the cell containing the formula will show in colour which cells are used in 
it. To revert to the normal display, hit the Escape key.

The demonstration will be given on Ubuntu 10.04 using OpenOffice.org version 3.2.1, and we will 
use an example of petrol consumption over a period of time. Some of the examples may look 
contrived, but I had to find some way of incorporating a demonstration without too much 
explanation of what the data represented.

Here is the screenshot of the example:

Naming sheets and cells
This example has two sheets in use. The name of a sheet can be changed by right clicking on the 
name of the sheet (tab near bottom left of window) and using Rename Sheet from the context menu.
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As readings are taken in miles for the distance travelled, and litres for the amount of petrol bought 
at any one time, but we want to see the consumption in terms of miles per gallon, there are some 
calculations to do to convert litres to gallons. As can be seen from the formula for the cell shown, 
that a reference is made to the name LperGallon (litres per gallon). This is the name of a cell that 
was established in the sheet named Constants, which contains:

The name of the selected cell you can see to the left of the formula bar near the top of the window. 
To define the name of a cell (or range of cells), select it (or them), and use Insert → Names → 
Define and follow the dialog. The name can then be used in formulae just like any other cell 
reference.

This example has been set up so as to easily switch between Imperial and US gallons by merely 
changing the contents of the selected cell in the picture. Whereas this feature may not be really 
useful for this sort of application, it would be useful when manipulating interest rates, or exchange 
rates.

Tip: If you are writing a formula for a cell, make sure you have finished with it before clicking on 
another cell to move the selection point. To finish with it, you can either hit the Enter or Escape 
key.

Tip: When rows are added into the middle of a table, then any references to a number of cells in the 
table are incremented accordingly. However, by default, this is not true when rows are added just 
beyond the end. To have new additions included, go to Tools → Options → Calc → General, and 
tick "Expand references when new columns/rows are inserted". Adding rows is now done using a 
right click on the row number (also known as the row header, and is the column on far left of the 
window). To add more than one row at a time, say three, select three rows above which you wish to 
insert the new three, and right click → Insert Rows as before.
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Pie Charts

Data Preparation

Pie charts can be drawn only by creating the relevant table of values which are to mapped onto the 
diagram. Suppose we wish to see where fuel has been bought. To do this, we first set up a table 
containing the values to be plotted. One way is to use the SUMIF function to sum all values in the 
Volume column corresponding to one of the places. Like this:

INSERT PICTURE: LocationSelection.png

The parameters to the SUMIF function are in turn:

1. The range of values which will determine what to select. In this case, it is the column of 
Places.

2. The condition to use on each of the values in the first parameter. In the case of equality, no 
'=' operator is given, but if comparisons are needed, then you can use things like '>50' to find 
all values greater than 50.

3. The range of values to sum according to the corresponding conditions applied to the first 
range. This can be omitted, in which case, it will be the same as the first range. In the 
present example, we want the sum of amounts from the Volume column corresponding to 
the location given in the Places column.

The highlighted cell has the formula:

=SUM($B$4:$B$16;$B18;E$4:E$16)
The dollar signs are to ensure that when the expression is copied to any new rows or columns, the 
array being summed remains the same for all.
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An alternative way of computing the sum is by using an array formula, like this:

=SUM((($B$4:$B$16)=$B19)*(E$4:E$16))
To make it into an array formula (rather than an ordinary one), instead of hitting Enter after writing 
it in the formula bar, an array formula is ended by using Cntrl+Shift+Enter.

What this function is doing is to add up all elements of the array formed by multiplying, in turn, 
E14 by (B14=B18), E15 by (B15=B18), etc. A logical test, like (B14=B18), returns a true or false 
indicator. In Calc, false is treated like zero, and true like one when the multiply is done. For those 
who know Excel, this will not work there; in Excel, logical results cannot take part in arithmetic 
operations.

When the formula is displayed in the formula bar, curly braces will surround it to show it is an array 
formula. However, these braces will disappear as soon as any editing of the formula is done. After 
any editing, Cntrl+Shift+Enter must again be applied to conserve its array status.

The advantage of using SUM rather than SUMIF is that it is much more general and can cope with 
more difficult situations.

The Pie Chart

Now we are in a position to prepare our pie chart. Pie charts are very simple, the basic one being a 
representation of a single batch of numbers showing each amount relative to the sum of all of them.

Select the cell about where you want the chart to appear, and then Insert → Chart to bring up the 
dialog. Under Chart Type, select Pie. Moving on to Data Range, we want to identify the values to be 
charted. This can be done graphically by hitting the “shrink” icon to the right of the input bar for the 
Data range. The names we want to use are in column B, and the values in column E. So to start 
with, we can drag the mouse over the rectangle from B18 to E20. We do not have labels to worry 
about in the columns, so untick First row as label. But we can keep First column as label since they 
can be used to identify the pieces of the pie.

The next step is to identify the precise series of numbers to be displayed in the chart. The starting 
point for that is under Data Series. Columns C and D have no data, so we can highlight in the left 
pane each of those in turn and hit Remove to take them out of consideration.

In the right pane, the Name line identifies the various series in the chart, but for a simple pie chart is 
there is only one, and this is not used. However, it would be used if the display was a column or row 
histogram. In that case, the name can be picked up from the contents of a cell. For example, by 
highlighting Name and then hitting the “shrink” icon by Range for Name, select E2 (containing 
Volume) and the name of the series will change. The y-values are p;cked up from column E 
correctly. You will also see the Category list already filled in to identify the names for the legend 
defining which colour means what in the chart.

Moving further to Chart elements, we can put a title into it, and say where the legend is to go, by 
default. These can be changed later if desired. Hitting Finish will set up the basic chart.

However, it may not be quite what you want. It is easiest if you tackle this now. For example, the 
default settings are to start at the 12 o'clock position, but go anti-clockwise round the circle. If we 
click on the pie chart itself, little green squares should appear in each of the sectors. Right click → 
Format Data Series gives you access to the various ways the results can be presented and can set 
them how you like.
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You will see that the starting angle is measured anticlockwise from the x-axis, just as the standard 
mathematical functions are normally defined and presented. So to start at 12 o'clock, the angle 
needs to be set to 90 degrees. The mark on the ring can be dragged round with the mouse if you 
want to.

In a similar way, the legend can be changed, e.g. changing the font used, or the size of font, etc.

The whole chart can be dragged and/or its size changed in the usual way for graphics, and the result 
might look like this:
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Other options

If you want to have labels on the sectors, instead of a legend, then again, select the chart, and if 
necessary, double click to get access to the individual elements of it. Then right click and Insert 
Data Labels. This starts with the values each piece of the pie represents. To put a different label (e.g. 
the category) there instead, click on one of the labels, followed by right click → Format Data 
Labels. Untick Show value as number, and tick Show category, and the labels will change to the 
names found in column B.

Finally, the legend can then be removed by selecting it and hitting the Delete key.

Column bars, or histograms

Another way of representing this data is via a histogram. But in this case, we can display more than 
one value per Place. So let's create some more data, just for the (stupid) example by copying cells 
E18:E20 into D18:D20 to give mileage per place (I know it's silly, but I'm trying to show how to 
draw charts from data).

Now when we create a chart by choosing type Column. Again, for the Data range, pick up from B18 
to E20 graphically, and then under Data Series, Remove Column C.

Continue by higlighting Column D under Data series, and then select Name in the right pane. Using 
the Shrink icon by the “Range for Name” input line, select D2 (Mileage), and repeat by highlighting 
Column E and select E2 to get better names for the values shown on the chart.

Then you should get something like this:
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Since this was purely for illustration, I deleted it again for the next phase of the example.

Defining graphs
For this example, let's see the consumption against time, that is column F against column A. Again, 
start with Insert → Chart but this time select Line if you want each row to be plotted at equidistant 
intervals, or X-Y (Scatter) if you want the values along the x-axis to be in their relative positions.

Let's choose Scatter plot for this example. Then select A4 to F16 in a big block. Unrtick First row as 
label, and First column as label. We will put names on later.

Under the Data Series, Remove Columns B to E, just leaving F. Then highlight Name in the right 
pane, and select F2, containing the inscription “mpg”. The x- and y-values are set correctly by 
default.

Under Chart elements, you can set up legends on various aspects of the graph as you want to see 
them. For this example, I just chose to set a Title and left the rest alone.

Going on to Finish, still leaves some adjustment to be made. So, select the points, and right click → 
Formnat Data Series. Then, we can change the icon used for the points on the graph in the right side 
of the Line tab. I went to Select Synbol, and chose the square at the top of the list. Then on the left 
part of the tab, I changed the colour to Chart 1 (a deep blue). To draw a line through them, choose a 
line Style of Continuous, and Width of zero, since otherwise it looks much too clunky.

Then by clicking on the x-axis and going to the Scale tab, we can untick the various Automatic 
settings we find inappropriate to set our own. I chose the first and last days of the year for the 
minimum and maximum values, and the interval to be 60 days (about 2 months) for the 
intermediate marks. Continuing with the selection of the x-axis, but moving on the Numbers tab, we 
can shorten the values printed to just month names by changing the format to be defined as MMM.

Similarly, we can change the scale and markings on the y-axis. I chose to go from 20 to 36 in steps 
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of 4.

Drawing trends (if you dare)

Finally, we can plot a trend line. Select the data points, right click → Insert trend line. From the 
Type tab, we can ask it to show the equation used as well as the type of plot (I chose Linear for the 
purposes of example). Then under the Line tab, choose a suitable colour (say, Chart 2 (Red)). The 
equation is dumped by default near the line, which is usually the wrong palce, so select it and drag 
it to a more readable location.

Like this:

Using in reports
To copy these charts into a text document written using Writer, or presentation with Impress, then 
just select the chart and Copy it to the clipboard in the usual way. It can then be pasted into the 
target document as expected and manipulated like a picture. 

Wrap up
Although this paper is brief, the demonstration should show how to get these effects in detail, as 
well as numerous other effects and results. The number of options is so great that it would be 
impractical to give detailed instructions for them all in a simple paper such as this.

Finally …
… when you have a problem, ask. There is a lot of help around.
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Further information
More on Calc can be most often found by using a search engine for the explicit question you may 
have. For example, the query “openoffice.org calc chart axis” leads to several detailed websites 
answering various questions on how to do specific things. For example, one found this way is: 
http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Calc_Guide/Creating_
a_chart

A number of other sites seem to have howto's on particular topics which I've found only by a search 
and they can sometimes answer the exact issue I had.
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