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More about Presentations with Impress

by Andy Pepperdine

This paper is intended some of the less obvious functions of the LibreOffice presentation 
application Impress. It will consider adding backgrounds to slides, making different slides have 
different appearances in the same presentation, changing the way one slide moves onto the next, 
and adding sound and vision where possible.

IMPORTANT NOTE for those who have LibreOffice installed on a recent version of Linux Mint. 
By default, some icons are not visible, which can make navigating Impress somewhat less than 
optimal. To fix this, ensure that the package libreoffice-style-tango is installed. That will restore 
them. You can check which style is in use by Tools → Options → View and look at the Icon Size 
and Style.

ALSO note that recent versions of LibreOffice seem to have a bug involved with sound files with 
Impress, especially those for transitions, which do not work under some installations. You may need
to install the package libreoffice-avmedia-backend-gstreamer in order to play during presentations.

After installing packages, LibreOffice must be re-started.

Preliminaries

When you start up Impress, the screen usually shows three panes, the left showing the slides that 
have been made so far, the centre one detail of the one you are working on, and the left changes 
according to what the current tasks are. The righ side is known as the task bar, and clicking on icons
down the right hand said can show common aspects that you may want to change associated with 
the currently selected object.

If you go to Format → Page and the Page tab, you should see the Format as Screen 4:3. This page 
size is not available to other applications in the LibreOffice suite except for Draw. So if you want 
special effects to be incorporated, Draw may give you the features you would like to create the 
inclusion.

Choosing a background

First, choose your background picture. It is important that it is not too dark or it will obscure the 
text, but it is not possible to modify it after it has been set as the background of a slide. So we need 
a way of lightening it so it is more like a faded watermark before including it on the slides. There 
are many ways of lightening a picture to be suitable as a background among the various image 
editing suites, e.g. GIMP, but as here we are looking at LibreOffice, I will explain how to use the 
Drawing features of Impress to perform a similar function of fading a selected image.

Layers

There are probably several other methods of doing this, but here is one. The basic idea is to place 
the image on the bottom layer, and then cover it with a plain white partially transparent layer. This 
gives the impression of looking through misted glass which will present a faded appearance of the 
lower image. Each of these parts can be independently moved forward and back through the stack 
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of layers to allow the image to be at the back, in front of which is the “glass” and finally at the front 
will be the text you will include for the presentation.

Inserting the image

To make this work properly and easily, I found the best way is not to set it as a background, but to 
insert the image onto a slide as it is.

Putting an image on is easy, just Insert → Image → From File and select your image. If it is large 
enough, it will fill the sheet. If it is not, then right click on the image will bring up the context menu
enabling you to modify it appropriately, like putting it the right place, etc.

You will notice that it will have obscured any text you have inserted. To move it to the back, right 
click and select Arrange → Send to Back.

Now we want to make it look more ghostly.

Creating the white layer

You will notice at the bottom of the window some icons for drawings. Using the rectangle icon 
create a new solid rectangle the same size as the sheet by drawing it from top left to bottom right to 
obscure the whole sheet. We now change its attributes to make the picture look as we want it.

Click on the rectangle so the little green squares appear at the corners and mid-sides. Then use right 
click → Area. Since we want to lighten the picture, under the Area tab, select Color from the 
dropdown list, and then the White colour. That gives us the colour to merge over the image.

Next go to the Transparency tab, select Transparency and set the amount to, say 25%. Then hit OK 
and see what it looks like. You can play with the various options for the rectangle to see what the 
best is for your particular situation.

Finally, right click → Arrange to put in the right place in the stack, for instance by sending it to the 
back, and then Bring Forward.

This has changed the current slide only. If you want others to be like it, then one way would be 
Insert → Duplicate Slide when creating a new one. However, there is a better way by means of 
master slides and templates, which will be described later.

Changing the background of a slide

When creating a presentation in Impress, the background on the current slide can be changed by 
going to Format → Page and the Background tab. The dropdown list gives various options of solid 
colours, hatchings, or shaded bitmaps, etc. But there is only a limited number of options listed there.

To use your own image as the background, then you need to go to Format → Area and then select 
the Bitmap tab. and use the Import button. Select and import the picture you want to use, and on 
returning to the Area dialog, it will have appeared in the bitmap list. Select it.

Then go to the Area tab and select Bitmap and the image you have chosen. You can then select 
whether to tile it, or to Autofill it by selecting the appropriate checkbox.

You will then be asked whether to apply it all slides or just this one.

However, that process only works with certain formats, so you would need to ensure that you have 
created the image in advance, and has the right appearance.
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Creating a master slide

Another, much more flexible, way is to set up a slide master with the images already installed, over 
which you can then place the presentation on each slide in turn. Here we will be making a master 
slide which can be re-used when required, for instance, by a company which wants to make all its 
slides conform to a house standard.

Starting from an empty presentation, go to View → Master →  Slide Master. Anything added when 
viewing the master will be included on all slides derived from this master. In particular, you will see
the various footer boxes supplied by default if you want to use them.

In addition, there is a small window with three icons and a button to close the master view. One of 
those icons (usually the leftmost) will create a new master to be included in the same presentation. 
Typically, you will probably want more than one type of slide. For example, the title slide may have
a different appearance from the bulk of the others, or you may wish to split your presentation into 
parts, each with their own characteristics. So it would always be a good idea to leave the default 
alone, and use that icon to create a new master with a suitable name you will recognise.

You will see on the master, boxes where a footer can be, including things like dates and slide 
numbers. The slide number is not enabled by default, and if you want it, then use View → Header 
and Footer to turn it on.

To include your image as the background, then you can put it onto the master in the same way as 
described above for any usual slide, and use the same technique to fade it if you need to. You can 
arrange the various objects from back to front just as before.

Finally, go back the normal view with Edit → Normal (or if the little dialog box is still present, then
there will be a Close Master View button you can use instead).

Now save it as a template by File → Templates → Save as Template in MyTemplates so it can be 
found again easily.

Selecting a master slide

To use these masters as the base for a new presentation, start with File → Wizards → Presentation 
from which you will be able to select and open the template saved, containing the master slides you 
need. It will be possible to change just one slide to something completely different if that is required
later.

NOTE: If you do not see any icons to the right of the sidebar in Impress, then it is likely that you 
are missing a style for LibreOffice. Read the first section of this paper.

To select the master page for a slide, use the icons on the right of the Sidebar – hovering the mouse 
over them show what they are in words.

Making transitions between slides more interesting

You may be bored with the standard methods of presenting one slide after another and are looking 
for something a little more jazzy. There are a lot of built-in transitions you can use. Click the 
Transitions icon by the Sidebar and you see them all. Selecting one will give a demonstration of 
what it will look like. The speed of the transition can be controlled to a limited extent, and a sound 
effect can also be included if you really want to annoy the audience.

Sound can be added to go along with the transition between slides.
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WARNING: Linux versions of LibreOffice seem to have lost the sound files, and I have not yet 
found how to restore them. However, there is a way round, and one that is probably safer to use in 
any case. If what I read is correct, then adding sound will not work when you move elsewhere 
unless the same sound file is in the same place on the presentation machine. So it would be best to 
develop the presentation in exactly the same place as it will be displayed from. So if you create your
work on a laptop, then display from the same laptop. If you want to take a USB, then put everything
you need on the USB and develop it there. Even then, there is no guarantee since the location of the 
USB will not necessarily be in the same place as where you did the work.

But back to sound files. To get them back for Linux, I moved copies from a Windows installation 
into a directory where I know where they are, and then used them as though they were additional to 
the built-in versions.

To add sound to a transition, select from the sound dropdown in the Transition pane, and select 
Other sound, from where you will be able to pick out the sound file that you want to use for the 
transition. It will add the new one to the end of the list.

Adding sound this way also gives you the opportunity to include a long sound file that will play 
during the slide, rther than just a clip to indicate the transition.

Animations

Animations govern how each element that you have installed in a slide are produced. So each line 
of text can be introduced separately on a mouse click, or faded in, or many other types of effects.

You cannot add a sound effect as well for each animation on a slide.

Embedding a video clip

Including a video file is easy. Just insert → Movie and Sound and then browse for the file you want.
You can then start it by the usual animations or transitions like any other object or slide.

Embedding a sound file

Sound files seem to have problems in LibreOffice on some systems, and there are bugs reported on 
the subject. But if you are patient, then it works the same way as for videos. For some reason, it can 
take a long time to insert the file, and just as long to move to the slide with the sound, and/or to start
it up. I hope it gets fixed fairly soon.

Adding sound to whole presentation

If, for instance, you want an automated slide show that has a sound file you want playing 
throughout the whole thing, then if you set up the first slide with a transition with sound from that 
file, set the timer on the transition instead of a mouse click, and apply it to all the slides, then it will 
continue from one to the next.

Further information

Full documentation on slides can be found at http://www.open-of-
course.org/courses/mod/url/view.php?id=832 and other chapters at the same site.
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Information on sound bug: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/823155

Some items on this page http://www.slideshare.net/smartchicago/impress-lesson-5 you may find of 
interest, too.
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